wifistix network connection

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

wifistix network connection

David Fonseca
Hello all,

I have been trying to get the wifistix-FCC to connect to my Zonet wifi network adapter card on my windows XP PC. I have followed the steps outlined in "WPA for wifistix" http://docwiki.gumstix.org/WPA_for_wifistix but I cannot see the gumstix through windows,

with a ifup mwlan0 i get:
udhcpc (v0.9.9-pre) started
Nothing to flush.


Also, my /etc/network/interfaces looks like:

# Configure Loopback
auto lo
iface lo inet loopback

auto usb0
iface usb0 inet dhcp

iface bnep0 inet dhcp

auto eth0
iface eth0 inet dhcp

iface eth1 inet dhcp

iface wlan0 inet dhcp

auto mwlan0
iface mwlan0 inet dhcp
    pre-up /sbin/wpa_supplicant -Bw -Dmarvell -imwlan0 -c/etc/wpa_supplicant.con
    post-down killall -q wpa_supplicant


My /etc/wpa_supplicant.conf :

ctrl_interface=/var/run/wpa_supplicant
network={
ssid="mySSID"
#psk="MYpassphrase"
psk=856a089e9327d42accb0d616d506e4216cd92c891e561a59899d5e0865f4b417
}


And iwconfig gives:

lo        no wireless extensions.

mwlan0    MRVL-CF8385  ESSID:""  Nickname:""
          Mode:Managed  Access Point: Not-Associated   Bit Rate=11 Mb/s
          Tx-Power=20 dBm
          Retry limit:8   RTS thr=2347 B   Fragment thr=2346 B
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:2
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

usb0      no wireless extensions.

I have completely searched the mail lists archives for solutions or leads to be able to connect two the devices. Please help.

David


-------------------------------------------------------------------------
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: wifistix network connection

C D-2
Assuming your wpa_supplicant file is correct, try this in the
/etc/network/interfaces file.
You seem to have a typo...
pre-up /sbin/wpa_supplicant -Bw -Dmarvell -imwlan0
-c/etc/wpa_supplicant.con <(RIGHT HERE)

put in the missing f
pre-up /sbin/wpa_supplicant -Bw -Dmarvell -imwlan0 -c/etc/wpa_supplicant.conf

That might fix it but if yours is anything like mine, it won't. In
that case I'll type out my work around.
Good luck.
Oh this also assumes your XP PC is acting like an access point and not adhoc.

- Chris

On 5/15/07, David Fonseca <[hidden email]> wrote:

> Hello all,
>
> I have been trying to get the wifistix-FCC to connect to my Zonet wifi
> network adapter card on my windows XP PC. I have followed the steps outlined
> in "WPA for wifistix"
> http://docwiki.gumstix.org/WPA_for_wifistix but I cannot
> see the gumstix through windows,
>
> with a ifup mwlan0 i get:
> udhcpc (v0.9.9-pre) started
> Nothing to flush.
>
>
> Also, my /etc/network/interfaces looks like:
>
> # Configure Loopback
> auto lo
> iface lo inet loopback
>
> auto usb0
> iface usb0 inet dhcp
>
> iface bnep0 inet dhcp
>
> auto eth0
> iface eth0 inet dhcp
>
> iface eth1 inet dhcp
>
> iface wlan0 inet dhcp
>
> auto mwlan0
> iface mwlan0 inet dhcp
>     pre-up /sbin/wpa_supplicant -Bw -Dmarvell -imwlan0
> -c/etc/wpa_supplicant.con
>     post-down killall -q wpa_supplicant
>
>
> My /etc/wpa_supplicant.conf :
>
>  ctrl_interface=/var/run/wpa_supplicant
> network={
> ssid="mySSID"
> #psk="MYpassphrase"
> psk=856a089e9327d42accb0d616d506e4216cd92c891e561a59899d5e0865f4b417
> }
>
>
> And iwconfig gives:
>
> lo        no wireless extensions.
>
> mwlan0    MRVL-CF8385  ESSID:""  Nickname:""
>           Mode:Managed  Access Point: Not-Associated   Bit Rate=11 Mb/s
>           Tx-Power=20 dBm
>           Retry limit:8   RTS thr=2347 B   Fragment thr=2346 B
>           Encryption key:off
>           Power Management:off
>           Link Quality:0  Signal level:0  Noise level:0
>           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:2
>           Tx excessive retries:0  Invalid misc:0   Missed beacon:0
>
> usb0      no wireless extensions.
>
> I have completely searched the mail lists archives for solutions or leads to
> be able to connect two the devices. Please help.
>
> David
>
>
> -------------------------------------------------------------------------
> This SF.net email is sponsored by DB2 Express
> Download DB2 Express C - the FREE version of DB2 express and take
> control of your XML. No limits. Just data. Click to get it now.
> http://sourceforge.net/powerbar/db2/
> _______________________________________________
> gumstix-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gumstix-users
>
>

-------------------------------------------------------------------------
This SF.net email is sponsored by DB2 Express
Download DB2 Express C - the FREE version of DB2 express and take
control of your XML. No limits. Just data. Click to get it now.
http://sourceforge.net/powerbar/db2/
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Loading...