subversion problems

classic Classic list List threaded Threaded
7 messages Options
j
Reply | Threaded
Open this post in threaded view
|

subversion problems

j
I can not install subversion from the repository as it download
aprutils even though its installed and has an install clash problem (I
have tried deleting the file and let ipk install it and still errors
with a file clash). I can not install the .ipk from the angstrom feed
browser due to the .ipk has an md5 sum missmatch, Cant build
subversion do to apr-util still being broken for me, I have posted the
apr-util issues awhile ago and still failing for me.

I can not build subversion on the image as make fails like about 8
others I need to install. Does anyone know how to fix apr-util to
build? Or does anyone know how I can get subversion on my image?

Thanks for any help

------------------------------------------------------------------------------
Beautiful is writing same markup. Internet Explorer 9 supports
standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
Spend less time writing and  rewriting code and more time creating great
experiences on the web. Be a part of the beta today.
http://p.sf.net/sfu/beautyoftheweb
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|

Re: subversion problems

Steve Sakoman
On Wed, Oct 6, 2010 at 1:39 PM, J. L. <[hidden email]> wrote:

> I can not install subversion from the repository as it download
> aprutils even though its installed and has an install clash problem (I
> have tried deleting the file and let ipk install it and still errors
> with a file clash). I can not install the .ipk from the angstrom feed
> browser due to the .ipk has an md5 sum missmatch, Cant build
> subversion do to apr-util still being broken for me, I have posted the
> apr-util issues awhile ago and still failing for me.
>
> I can not build subversion on the image as make fails like about 8
> others I need to install. Does anyone know how to fix apr-util to
> build? Or does anyone know how I can get subversion on my image?

I'm puzzled why subversion won't build for you.  It builds with no
issues on my Ubuntu 10.04 system:

http://build.sakoman.com/packages/11522/

The apr-util package also builds for me:

http://build.sakoman.com/packages/11524/

I hate issues like this!  I suspect that I probably have a package
installed on my build machine that you are missing.  What it is, I
have no idea :-(

Steve

------------------------------------------------------------------------------
Beautiful is writing same markup. Internet Explorer 9 supports
standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
Spend less time writing and  rewriting code and more time creating great
experiences on the web. Be a part of the beta today.
http://p.sf.net/sfu/beautyoftheweb
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
j
Reply | Threaded
Open this post in threaded view
|

Re: subversion problems

j
On Wed, Oct 6, 2010 at 4:31 PM, Steve Sakoman <[hidden email]> wrote:

> On Wed, Oct 6, 2010 at 1:39 PM, J. L. <[hidden email]> wrote:
>> I can not install subversion from the repository as it download
>> aprutils even though its installed and has an install clash problem (I
>> have tried deleting the file and let ipk install it and still errors
>> with a file clash). I can not install the .ipk from the angstrom feed
>> browser due to the .ipk has an md5 sum missmatch, Cant build
>> subversion do to apr-util still being broken for me, I have posted the
>> apr-util issues awhile ago and still failing for me.
>>
>> I can not build subversion on the image as make fails like about 8
>> others I need to install. Does anyone know how to fix apr-util to
>> build? Or does anyone know how I can get subversion on my image?
>
> I'm puzzled why subversion won't build for you.  It builds with no
> issues on my Ubuntu 10.04 system:
>
> http://build.sakoman.com/packages/11522/
>
> The apr-util package also builds for me:
>
> http://build.sakoman.com/packages/11524/
>
> I hate issues like this!  I suspect that I probably have a package
> installed on my build machine that you are missing.  What it is, I
> have no idea :-(
>
> Steve
>
> ------------------------------------------------------------------------------
> Beautiful is writing same markup. Internet Explorer 9 supports
> standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
> Spend less time writing and  rewriting code and more time creating great
> experiences on the web. Be a part of the beta today.
> http://p.sf.net/sfu/beautyoftheweb
> _______________________________________________
> gumstix-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gumstix-users
>

It always fails on apr-utils so not sure if actually subversion
fails.. I guess I will start search any possible packages related to
apr that I may not have. Thanks for the input Steve if I figure out
something I will post the result but I have so many dead ends right
now its frustrating.

------------------------------------------------------------------------------
Beautiful is writing same markup. Internet Explorer 9 supports
standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
Spend less time writing and  rewriting code and more time creating great
experiences on the web. Be a part of the beta today.
http://p.sf.net/sfu/beautyoftheweb
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|

Re: subversion problems

Alex Gibson-3
In reply to this post by Steve Sakoman
  On 7/10/2010 10:31 AM, Steve Sakoman wrote:

> On Wed, Oct 6, 2010 at 1:39 PM, J. L.<[hidden email]>  wrote:
>> I can not install subversion from the repository as it download
>> aprutils even though its installed and has an install clash problem (I
>> have tried deleting the file and let ipk install it and still errors
>> with a file clash). I can not install the .ipk from the angstrom feed
>> browser due to the .ipk has an md5 sum missmatch, Cant build
>> subversion do to apr-util still being broken for me, I have posted the
>> apr-util issues awhile ago and still failing for me.
>>
>> I can not build subversion on the image as make fails like about 8
>> others I need to install. Does anyone know how to fix apr-util to
>> build? Or does anyone know how I can get subversion on my image?
> I'm puzzled why subversion won't build for you.  It builds with no
> issues on my Ubuntu 10.04 system:
>
> http://build.sakoman.com/packages/11522/
>
> The apr-util package also builds for me:
>
> http://build.sakoman.com/packages/11524/
>
> I hate issues like this!  I suspect that I probably have a package
> installed on my build machine that you are missing.  What it is, I
> have no idea :-(
>
> Steve

Builds fine here on fedora 13
with the latest git pull.

JL can you try a completely clean build from scratch ?
You haven't mixed overo and psp headers or packages in your /overo-oe/  
build path  ?

--
UTS CRICOS Provider Code:  00099F
DISCLAIMER: This email message and any accompanying attachments may contain
confidential information.  If you are not the intended recipient, do not
read, use, disseminate, distribute or copy this message or attachments.  If
you have received this message in error, please notify the sender
immediately and delete this message. Any views expressed in this message
are those of the individual sender, except where the sender expressly, and
with authority, states them to be the views the University of Technology,
Sydney. Before opening any attachments, please check them for viruses and
defects.

------------------------------------------------------------------------------
Beautiful is writing same markup. Internet Explorer 9 supports
standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
Spend less time writing and  rewriting code and more time creating great
experiences on the web. Be a part of the beta today.
http://p.sf.net/sfu/beautyoftheweb
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
j
Reply | Threaded
Open this post in threaded view
|

Re: subversion problems

j
On Wed, Oct 6, 2010 at 5:02 PM, Alex Gibson <[hidden email]> wrote:

>  On 7/10/2010 10:31 AM, Steve Sakoman wrote:
>> On Wed, Oct 6, 2010 at 1:39 PM, J. L.<[hidden email]>  wrote:
>>> I can not install subversion from the repository as it download
>>> aprutils even though its installed and has an install clash problem (I
>>> have tried deleting the file and let ipk install it and still errors
>>> with a file clash). I can not install the .ipk from the angstrom feed
>>> browser due to the .ipk has an md5 sum missmatch, Cant build
>>> subversion do to apr-util still being broken for me, I have posted the
>>> apr-util issues awhile ago and still failing for me.
>>>
>>> I can not build subversion on the image as make fails like about 8
>>> others I need to install. Does anyone know how to fix apr-util to
>>> build? Or does anyone know how I can get subversion on my image?
>> I'm puzzled why subversion won't build for you.  It builds with no
>> issues on my Ubuntu 10.04 system:
>>
>> http://build.sakoman.com/packages/11522/
>>
>> The apr-util package also builds for me:
>>
>> http://build.sakoman.com/packages/11524/
>>
>> I hate issues like this!  I suspect that I probably have a package
>> installed on my build machine that you are missing.  What it is, I
>> have no idea :-(
>>
>> Steve
>
> Builds fine here on fedora 13
> with the latest git pull.
>
> JL can you try a completely clean build from scratch ?
> You haven't mixed overo and psp headers or packages in your /overo-oe/
> build path  ?
>
> --
> UTS CRICOS Provider Code:  00099F
> DISCLAIMER: This email message and any accompanying attachments may contain
> confidential information.  If you are not the intended recipient, do not
> read, use, disseminate, distribute or copy this message or attachments.  If
> you have received this message in error, please notify the sender
> immediately and delete this message. Any views expressed in this message
> are those of the individual sender, except where the sender expressly, and
> with authority, states them to be the views the University of Technology,
> Sydney. Before opening any attachments, please check them for viruses and
> defects.
>
> ------------------------------------------------------------------------------
> Beautiful is writing same markup. Internet Explorer 9 supports
> standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
> Spend less time writing and  rewriting code and more time creating great
> experiences on the web. Be a part of the beta today.
> http://p.sf.net/sfu/beautyoftheweb
> _______________________________________________
> gumstix-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gumstix-users
>

All this is on a fresh build deleted tmp and started the build all
over. I have learned to just delete tmp everytime I do a pull and do a
fresh build

------------------------------------------------------------------------------
Beautiful is writing same markup. Internet Explorer 9 supports
standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
Spend less time writing and  rewriting code and more time creating great
experiences on the web. Be a part of the beta today.
http://p.sf.net/sfu/beautyoftheweb
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
j
Reply | Threaded
Open this post in threaded view
|

Re: subversion problems

j
On Wed, Oct 6, 2010 at 5:08 PM, J. L. <[hidden email]> wrote:

> On Wed, Oct 6, 2010 at 5:02 PM, Alex Gibson <[hidden email]> wrote:
>>  On 7/10/2010 10:31 AM, Steve Sakoman wrote:
>>> On Wed, Oct 6, 2010 at 1:39 PM, J. L.<[hidden email]>  wrote:
>>>> I can not install subversion from the repository as it download
>>>> aprutils even though its installed and has an install clash problem (I
>>>> have tried deleting the file and let ipk install it and still errors
>>>> with a file clash). I can not install the .ipk from the angstrom feed
>>>> browser due to the .ipk has an md5 sum missmatch, Cant build
>>>> subversion do to apr-util still being broken for me, I have posted the
>>>> apr-util issues awhile ago and still failing for me.
>>>>
>>>> I can not build subversion on the image as make fails like about 8
>>>> others I need to install. Does anyone know how to fix apr-util to
>>>> build? Or does anyone know how I can get subversion on my image?
>>> I'm puzzled why subversion won't build for you.  It builds with no
>>> issues on my Ubuntu 10.04 system:
>>>
>>> http://build.sakoman.com/packages/11522/
>>>
>>> The apr-util package also builds for me:
>>>
>>> http://build.sakoman.com/packages/11524/
>>>
>>> I hate issues like this!  I suspect that I probably have a package
>>> installed on my build machine that you are missing.  What it is, I
>>> have no idea :-(
>>>
>>> Steve
>>
>> Builds fine here on fedora 13
>> with the latest git pull.
>>
>> JL can you try a completely clean build from scratch ?
>> You haven't mixed overo and psp headers or packages in your /overo-oe/
>> build path  ?
>>
>> --
>> UTS CRICOS Provider Code:  00099F
>> DISCLAIMER: This email message and any accompanying attachments may contain
>> confidential information.  If you are not the intended recipient, do not
>> read, use, disseminate, distribute or copy this message or attachments.  If
>> you have received this message in error, please notify the sender
>> immediately and delete this message. Any views expressed in this message
>> are those of the individual sender, except where the sender expressly, and
>> with authority, states them to be the views the University of Technology,
>> Sydney. Before opening any attachments, please check them for viruses and
>> defects.
>>
>> ------------------------------------------------------------------------------
>> Beautiful is writing same markup. Internet Explorer 9 supports
>> standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
>> Spend less time writing and  rewriting code and more time creating great
>> experiences on the web. Be a part of the beta today.
>> http://p.sf.net/sfu/beautyoftheweb
>> _______________________________________________
>> gumstix-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/gumstix-users
>>
>
> All this is on a fresh build deleted tmp and started the build all
> over. I have learned to just delete tmp everytime I do a pull and do a
> fresh build
>

you had it right steve I just added everything apr related I could
find and it finally built.. Thanks a bunch

------------------------------------------------------------------------------
Beautiful is writing same markup. Internet Explorer 9 supports
standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
Spend less time writing and  rewriting code and more time creating great
experiences on the web. Be a part of the beta today.
http://p.sf.net/sfu/beautyoftheweb
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
j
Reply | Threaded
Open this post in threaded view
|

Re: subversion problems

j
On Wed, Oct 6, 2010 at 9:24 PM, J. L. <[hidden email]> wrote:

> On Wed, Oct 6, 2010 at 5:08 PM, J. L. <[hidden email]> wrote:
>> On Wed, Oct 6, 2010 at 5:02 PM, Alex Gibson <[hidden email]> wrote:
>>>  On 7/10/2010 10:31 AM, Steve Sakoman wrote:
>>>> On Wed, Oct 6, 2010 at 1:39 PM, J. L.<[hidden email]>  wrote:
>>>>> I can not install subversion from the repository as it download
>>>>> aprutils even though its installed and has an install clash problem (I
>>>>> have tried deleting the file and let ipk install it and still errors
>>>>> with a file clash). I can not install the .ipk from the angstrom feed
>>>>> browser due to the .ipk has an md5 sum missmatch, Cant build
>>>>> subversion do to apr-util still being broken for me, I have posted the
>>>>> apr-util issues awhile ago and still failing for me.
>>>>>
>>>>> I can not build subversion on the image as make fails like about 8
>>>>> others I need to install. Does anyone know how to fix apr-util to
>>>>> build? Or does anyone know how I can get subversion on my image?
>>>> I'm puzzled why subversion won't build for you.  It builds with no
>>>> issues on my Ubuntu 10.04 system:
>>>>
>>>> http://build.sakoman.com/packages/11522/
>>>>
>>>> The apr-util package also builds for me:
>>>>
>>>> http://build.sakoman.com/packages/11524/
>>>>
>>>> I hate issues like this!  I suspect that I probably have a package
>>>> installed on my build machine that you are missing.  What it is, I
>>>> have no idea :-(
>>>>
>>>> Steve
>>>
>>> Builds fine here on fedora 13
>>> with the latest git pull.
>>>
>>> JL can you try a completely clean build from scratch ?
>>> You haven't mixed overo and psp headers or packages in your /overo-oe/
>>> build path  ?
>>>
>>> --
>>> UTS CRICOS Provider Code:  00099F
>>> DISCLAIMER: This email message and any accompanying attachments may contain
>>> confidential information.  If you are not the intended recipient, do not
>>> read, use, disseminate, distribute or copy this message or attachments.  If
>>> you have received this message in error, please notify the sender
>>> immediately and delete this message. Any views expressed in this message
>>> are those of the individual sender, except where the sender expressly, and
>>> with authority, states them to be the views the University of Technology,
>>> Sydney. Before opening any attachments, please check them for viruses and
>>> defects.
>>>
>>> ------------------------------------------------------------------------------
>>> Beautiful is writing same markup. Internet Explorer 9 supports
>>> standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
>>> Spend less time writing and  rewriting code and more time creating great
>>> experiences on the web. Be a part of the beta today.
>>> http://p.sf.net/sfu/beautyoftheweb
>>> _______________________________________________
>>> gumstix-users mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/gumstix-users
>>>
>>
>> All this is on a fresh build deleted tmp and started the build all
>> over. I have learned to just delete tmp everytime I do a pull and do a
>> fresh build
>>
>
> you had it right steve I just added everything apr related I could
> find and it finally built.. Thanks a bunch
>

Though I am not sure the exact package like I said I know it was not
from installing:
sudo apt-get install apache2 apr-util apr-util-dev

it was something else in snaptic that came up with apr as the search,
there was like 3 libraries left and it was one of the 3, didnt think
it would work so didnt think to pay close attention.

------------------------------------------------------------------------------
Beautiful is writing same markup. Internet Explorer 9 supports
standards for HTML5, CSS3, SVG 1.1,  ECMAScript5, and DOM L2 & L3.
Spend less time writing and  rewriting code and more time creating great
experiences on the web. Be a part of the beta today.
http://p.sf.net/sfu/beautyoftheweb
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users