Quantcast

Yocto Denzil - PHP recipe fails on dev build

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Yocto Denzil - PHP recipe fails on dev build

Ryan
I'm using Yocto 1.2 (denzil), and I'm having troubles with the PHP recipe in meta-openembedded/meta-oe. My image recipes are based off of the ones in the meta-gumstix layer, but I have modified them to add/remove various recipes. When I build a regular console build without the dev packages, the build works fine. When I try to build the console-dev image (with IMAGE_FEATURES += "dev-pkgs"), the build fails with the following error:

error: Failed dependencies:
|       libc-client = 2007e-r0 is needed by libc-client-dev-2007e-r0.armv7a

The libc-client recipe is present in the build in meta-openembedded/meta-oe, and it builds fine without the dev packages, so I don't understand what the problem is.

Has anyone else had trouble with the PHP recipe?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Yocto Denzil - PHP recipe fails on dev build

Ryan
I solved by problem. I created a "libc-client_2007e.bbappend" file and put PACKAGES = "${PN}" inside of it, so that it wouldn't try to build the -dev package. This may not be ideal for everyone, but it worked for my purposes.
Loading...