Quantcast

Updating libc6 on Verdex

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Updating libc6 on Verdex

dasanchez
Hi all,

I am trying to port some applications to Qt5 on a Verdex.

I installed the g++-arm-linux-gnueabi package in the host machine and cross-compiled Qt 5.0.2 against it.
I compiled a test program successfully, but when I tried running it on the Verdex I ran into some trouble-

/lib/libstdc++.so.6: no version information available
/lib/libc6.so: version 'GLIBC_2.15' not found
/lib/libc6.so: version 'GLIBC_2.7' not found
/lib/libc6.so: version 'GLIBC_2.9' not found

I can replace the libstdc++ libraries I have in the /lib folder because they're only required by my Qt applications, but I'm hesitant to overwrite all the libc6-related ones (I have the latest version sitting in my host machine).

I tried running:

ipkg upgrade libc6

But it looks like the packages from gumstix.net don't have anything newer than 2.5.

Can I have some help regarding what I can do to upgrade my libc6 libraries?

Thanks,

Dante
Loading...