Quantcast

SET failed on device wlan0 ; No such device. Error

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

SET failed on device wlan0 ; No such device. Error

titusgroan
Hi

I have an overo fire+summit and am trying to setup the wifi by following the instructions located at:
http://www.gumstix.net/wiki/index.php?title=Overo_Wifi

When I enter the line  "iwconfig wlan0 essid any" as suggested on this page the following error is thrown:

Error for wireless request "Set ESSID" (8B1A) :
    SET failed on device wlan0 ; No such device.

Any ideas how to fix this would be great

Thanks

Titusgroan



 
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SET failed on device wlan0 ; No such device. Error

Brett Graham-3
Did you try running iwconfig with no arguments and see if wlan0 is listed?

If not, try running "ifup wlan0" to bring 'up' the interface.

Also, depending on what image you used, the wireless interface may not
be wlan0, on my image (built with bitbake) the wireless interface is
configured as eth0.

On Sat, Oct 3, 2009 at 10:20 AM, titusgroan
<[hidden email]> wrote:

>
> Hi
>
> I have an overo fire+summit and am trying to setup the wifi by following the
> instructions located at:
> http://www.gumstix.net/wiki/index.php?title=Overo_Wifi
>
> When I enter the line  "iwconfig wlan0 essid any" as suggested on this page
> the following error is thrown:
>
> Error for wireless request "Set ESSID" (8B1A) :
>    SET failed on device wlan0 ; No such device.
>
> Any ideas how to fix this would be great
>
> Thanks
>
> Titusgroan
>
>
>
>
> --
> View this message in context: http://www.nabble.com/SET-failed-on-device-wlan0---No-such-device.-Error-tp25729233p25729233.html
> Sent from the Gumstix mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> Come build with us! The BlackBerry&reg; Developer Conference in SF, CA
> is the only developer event you need to attend this year. Jumpstart your
> developing skills, take BlackBerry mobile applications to market and stay
> ahead of the curve. Join us from November 9&#45;12, 2009. Register now&#33;
> http://p.sf.net/sfu/devconf
> _______________________________________________
> gumstix-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gumstix-users
>

------------------------------------------------------------------------------
Come build with us! The BlackBerry&reg; Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay
ahead of the curve. Join us from November 9&#45;12, 2009. Register now&#33;
http://p.sf.net/sfu/devconf
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SET failed on device wlan0 ; No such device. Error

titusgroan
Hi

Here is the output after typing your suggested commands:

root@overo:~# iwconfig
lo        no wireless extensions.

root@overo:~# ifup wlan0
ifup: interface wlan0 already configured

root@overo:~# ifup eth0
ifup: interface eth0 already configured

It seems to recognize the presence of the connections using the second command only for some reason? Any ideas

Thanks

Titusgroan




Brett Graham-3 wrote
Did you try running iwconfig with no arguments and see if wlan0 is listed?

If not, try running "ifup wlan0" to bring 'up' the interface.

Also, depending on what image you used, the wireless interface may not
be wlan0, on my image (built with bitbake) the wireless interface is
configured as eth0.

On Sat, Oct 3, 2009 at 10:20 AM, titusgroan
<rahul.summan@eee.strath.ac.uk> wrote:
>
> Hi
>
> I have an overo fire+summit and am trying to setup the wifi by following the
> instructions located at:
> http://www.gumstix.net/wiki/index.php?title=Overo_Wifi
>
> When I enter the line  "iwconfig wlan0 essid any" as suggested on this page
> the following error is thrown:
>
> Error for wireless request "Set ESSID" (8B1A) :
>    SET failed on device wlan0 ; No such device.
>
> Any ideas how to fix this would be great
>
> Thanks
>
> Titusgroan
>
>
>
>
> --
> View this message in context: http://www.nabble.com/SET-failed-on-device-wlan0---No-such-device.-Error-tp25729233p25729233.html
> Sent from the Gumstix mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> Come build with us! The BlackBerry® Developer Conference in SF, CA
> is the only developer event you need to attend this year. Jumpstart your
> developing skills, take BlackBerry mobile applications to market and stay
> ahead of the curve. Join us from November 9-12, 2009. Register now!
> http://p.sf.net/sfu/devconf
> _______________________________________________
> gumstix-users mailing list
> gumstix-users@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/gumstix-users
>

------------------------------------------------------------------------------
Come build with us! The BlackBerry® Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay
ahead of the curve. Join us from November 9-12, 2009. Register now!
http://p.sf.net/sfu/devconf
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SET failed on device wlan0 ; No such device. Error

Brett Graham-3
can you post the contents of your /etc/network/interfaces file and
also try taking the interface down and then back up:
ifdown wlan0
ifup wlan0

also, could you post the output of ifconfig and iwconfig after running
the previous commands.

On Sat, Oct 3, 2009 at 11:30 AM, titusgroan
<[hidden email]> wrote:

>
> Hi
>
> Here is the output after typing your suggested commands:
>
> root@overo:~# iwconfig
> lo        no wireless extensions.
>
> root@overo:~# ifup wlan0
> ifup: interface wlan0 already configured
>
> root@overo:~# ifup eth0
> ifup: interface eth0 already configured
>
> It seems to recognize the presence of the connections using the second
> command only for some reason? Any ideas
>
> Thanks
>
> Titusgroan
>
>
>
>
>
> Brett Graham-3 wrote:
>>
>> Did you try running iwconfig with no arguments and see if wlan0 is listed?
>>
>> If not, try running "ifup wlan0" to bring 'up' the interface.
>>
>> Also, depending on what image you used, the wireless interface may not
>> be wlan0, on my image (built with bitbake) the wireless interface is
>> configured as eth0.
>>
>> On Sat, Oct 3, 2009 at 10:20 AM, titusgroan
>> <[hidden email]> wrote:
>>>
>>> Hi
>>>
>>> I have an overo fire+summit and am trying to setup the wifi by following
>>> the
>>> instructions located at:
>>> http://www.gumstix.net/wiki/index.php?title=Overo_Wifi
>>>
>>> When I enter the line  "iwconfig wlan0 essid any" as suggested on this
>>> page
>>> the following error is thrown:
>>>
>>> Error for wireless request "Set ESSID" (8B1A) :
>>>    SET failed on device wlan0 ; No such device.
>>>
>>> Any ideas how to fix this would be great
>>>
>>> Thanks
>>>
>>> Titusgroan
>>>
>>>
>>>
>>>
>>> --
>>> View this message in context:
>>> http://www.nabble.com/SET-failed-on-device-wlan0---No-such-device.-Error-tp25729233p25729233.html
>>> Sent from the Gumstix mailing list archive at Nabble.com.
>>>
>>>
>>> ------------------------------------------------------------------------------
>>> Come build with us! The BlackBerry&reg; Developer Conference in SF, CA
>>> is the only developer event you need to attend this year. Jumpstart your
>>> developing skills, take BlackBerry mobile applications to market and stay
>>> ahead of the curve. Join us from November 9&#45;12, 2009. Register
>>> now&#33;
>>> http://p.sf.net/sfu/devconf
>>> _______________________________________________
>>> gumstix-users mailing list
>>> [hidden email]
>>> https://lists.sourceforge.net/lists/listinfo/gumstix-users
>>>
>>
>> ------------------------------------------------------------------------------
>> Come build with us! The BlackBerry&reg; Developer Conference in SF, CA
>> is the only developer event you need to attend this year. Jumpstart your
>> developing skills, take BlackBerry mobile applications to market and stay
>> ahead of the curve. Join us from November 9&#45;12, 2009. Register
>> now&#33;
>> http://p.sf.net/sfu/devconf
>> _______________________________________________
>> gumstix-users mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/gumstix-users
>>
>>
>
> --
> View this message in context: http://www.nabble.com/SET-failed-on-device-wlan0---No-such-device.-Error-tp25729233p25729878.html
> Sent from the Gumstix mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> Come build with us! The BlackBerry&reg; Developer Conference in SF, CA
> is the only developer event you need to attend this year. Jumpstart your
> developing skills, take BlackBerry mobile applications to market and stay
> ahead of the curve. Join us from November 9&#45;12, 2009. Register now&#33;
> http://p.sf.net/sfu/devconf
> _______________________________________________
> gumstix-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gumstix-users
>

------------------------------------------------------------------------------
Come build with us! The BlackBerry&reg; Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay
ahead of the curve. Join us from November 9&#45;12, 2009. Register now&#33;
http://p.sf.net/sfu/devconf
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SET failed on device wlan0 ; No such device. Error

titusgroan
Hi

I tried

ifdown eth0
ifup eth0

and its now working.

Thanks chaps

Titusgroan


Brett Graham-3 wrote
can you post the contents of your /etc/network/interfaces file and
also try taking the interface down and then back up:
ifdown wlan0
ifup wlan0

also, could you post the output of ifconfig and iwconfig after running
the previous commands.

On Sat, Oct 3, 2009 at 11:30 AM, titusgroan
<rahul.summan@eee.strath.ac.uk> wrote:
>
> Hi
>
> Here is the output after typing your suggested commands:
>
> root@overo:~# iwconfig
> lo        no wireless extensions.
>
> root@overo:~# ifup wlan0
> ifup: interface wlan0 already configured
>
> root@overo:~# ifup eth0
> ifup: interface eth0 already configured
>
> It seems to recognize the presence of the connections using the second
> command only for some reason? Any ideas
>
> Thanks
>
> Titusgroan
>
>
>
>
>
> Brett Graham-3 wrote:
>>
>> Did you try running iwconfig with no arguments and see if wlan0 is listed?
>>
>> If not, try running "ifup wlan0" to bring 'up' the interface.
>>
>> Also, depending on what image you used, the wireless interface may not
>> be wlan0, on my image (built with bitbake) the wireless interface is
>> configured as eth0.
>>
>> On Sat, Oct 3, 2009 at 10:20 AM, titusgroan
>> <rahul.summan@eee.strath.ac.uk> wrote:
>>>
>>> Hi
>>>
>>> I have an overo fire+summit and am trying to setup the wifi by following
>>> the
>>> instructions located at:
>>> http://www.gumstix.net/wiki/index.php?title=Overo_Wifi
>>>
>>> When I enter the line  "iwconfig wlan0 essid any" as suggested on this
>>> page
>>> the following error is thrown:
>>>
>>> Error for wireless request "Set ESSID" (8B1A) :
>>>    SET failed on device wlan0 ; No such device.
>>>
>>> Any ideas how to fix this would be great
>>>
>>> Thanks
>>>
>>> Titusgroan
>>>
>>>
>>>
>>>
>>> --
>>> View this message in context:
>>> http://www.nabble.com/SET-failed-on-device-wlan0---No-such-device.-Error-tp25729233p25729233.html
>>> Sent from the Gumstix mailing list archive at Nabble.com.
>>>
>>>
>>> ------------------------------------------------------------------------------
>>> Come build with us! The BlackBerry® Developer Conference in SF, CA
>>> is the only developer event you need to attend this year. Jumpstart your
>>> developing skills, take BlackBerry mobile applications to market and stay
>>> ahead of the curve. Join us from November 9-12, 2009. Register
>>> now!
>>> http://p.sf.net/sfu/devconf
>>> _______________________________________________
>>> gumstix-users mailing list
>>> gumstix-users@lists.sourceforge.net
>>> https://lists.sourceforge.net/lists/listinfo/gumstix-users
>>>
>>
>> ------------------------------------------------------------------------------
>> Come build with us! The BlackBerry® Developer Conference in SF, CA
>> is the only developer event you need to attend this year. Jumpstart your
>> developing skills, take BlackBerry mobile applications to market and stay
>> ahead of the curve. Join us from November 9-12, 2009. Register
>> now!
>> http://p.sf.net/sfu/devconf
>> _______________________________________________
>> gumstix-users mailing list
>> gumstix-users@lists.sourceforge.net
>> https://lists.sourceforge.net/lists/listinfo/gumstix-users
>>
>>
>
> --
> View this message in context: http://www.nabble.com/SET-failed-on-device-wlan0---No-such-device.-Error-tp25729233p25729878.html
> Sent from the Gumstix mailing list archive at Nabble.com.
>
>
> ------------------------------------------------------------------------------
> Come build with us! The BlackBerry® Developer Conference in SF, CA
> is the only developer event you need to attend this year. Jumpstart your
> developing skills, take BlackBerry mobile applications to market and stay
> ahead of the curve. Join us from November 9-12, 2009. Register now!
> http://p.sf.net/sfu/devconf
> _______________________________________________
> gumstix-users mailing list
> gumstix-users@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/gumstix-users
>

------------------------------------------------------------------------------
Come build with us! The BlackBerry® Developer Conference in SF, CA
is the only developer event you need to attend this year. Jumpstart your
developing skills, take BlackBerry mobile applications to market and stay
ahead of the curve. Join us from November 9-12, 2009. Register now!
http://p.sf.net/sfu/devconf
_______________________________________________
gumstix-users mailing list
gumstix-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SET failed on device wlan0 ; No such device. Error

kfcandroid
I was wondering is anyone got this issue solved?
currently I'm running stable stock images in flash (not from SD)
http://cumulus.gumstix.org/images/angstrom/factory/2011-03-25-1619/

here's my result:

root@overo:~# iwconfig
lo        no wireless extensions.

eth1      no wireless extensions.

root@overo:~# ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

root@overo:~#


Here's the file I configured in my /etc/network/interfaces:
#modification made 9-25-12 for uncrypted network
allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
        pre-up /sbin/iwconfig wlan0 essid any
        wireless_mode managed


Is there anything I can do to bring up my wifi?
BTW, I'm totally new to this world so would you please provide me instructions or hints, so I can
learn from it.

Thanks in advance!
James
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SET failed on device wlan0 ; No such device. Error

sbaskana
Try the instructions on this link:


Sometimes, disabling the network manager can solve this type of issues.

Good luck!

On Tue, Sep 25, 2012 at 6:50 PM, kfcandroid <[hidden email]> wrote:
I was wondering is anyone got this issue solved?
currently I'm running stable stock images in flash (not from SD)
http://cumulus.gumstix.org/images/angstrom/factory/2011-03-25-1619/

here's my result:

root@overo:~# iwconfig
lo        no wireless extensions.

eth1      no wireless extensions.

root@overo:~# ifconfig
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

root@overo:~#


Here's the file I configured in my /etc/network/interfaces:
#modification made 9-25-12 for uncrypted network
allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
        pre-up /sbin/iwconfig wlan0 essid any
        wireless_mode managed


Is there anything I can do to bring up my wifi?
BTW, I'm totally new to this world so would you please provide me
instructions or hints, so I can
learn from it.

Thanks in advance!
James



--
View this message in context: http://gumstix.8.n6.nabble.com/SET-failed-on-device-wlan0-No-such-device-Error-tp657513p4965501.html
Sent from the Gumstix mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users


------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SET failed on device wlan0 ; No such device. Error

kfcandroid
Thanks for the link, Sebastian,
I followed those steps without any problem until I was told to enable wifi manually by following the code below:

ESSID='Apt Rm 04 & 05' # CHANGE THIS to suite your situation
ifdown -a
ifconfig wlan0 down
iwconfig wlan0 bit 18M fixed
iwconfig wlan0 essid "${ESSID}"
iwconfig wlan0 mode managed
iwconfig wlan0 key off
dhclient wlan0


when I type in "ifconfig wlan0 down", it gets me the same error message:

 Error for wireless request "Set ESSID" (8B1A) :
   SET failed on device wlan0 ; no cush device.
 Failed to bring up wlan0.


I did STOP and REMOVED the Network Manager by doing this:
root@overo:~# opkg remove networkmanager

anyone has idea about what happened to my Overo Fire?
Should I try a different kernel, image, or its a hardware issue?

Thanks in advance.

James
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SET failed on device wlan0 ; No such device. Error

sbaskana
Are you sure your device name is "wlan0" and not "wlan3" or whatever?

What does the command "iwconfig" show?

On Wed, Sep 26, 2012 at 3:09 PM, kfcandroid <[hidden email]> wrote:
Thanks for the link, Sebastian,
I followed those steps without any problem until I was told to enable wifi
manually by following the code below:

/ESSID='Apt Rm 04 & 05' # CHANGE THIS to suite your situation
ifdown -a
ifconfig wlan0 down
iwconfig wlan0 bit 18M fixed
iwconfig wlan0 essid "${ESSID}"
iwconfig wlan0 mode managed
iwconfig wlan0 key off
dhclient wlan0/

when I type in "ifconfig wlan0 down", it gets me the same error message:

/ Error for wireless request "Set ESSID" (8B1A) :
   SET failed on device wlan0 ; no cush device.
 Failed to bring up wlan0./

I did STOP and REMOVED the Network Manager by doing this:
root@overo:~# opkg remove networkmanager

anyone has idea about what happened to my Overo Fire?
Should I try a different kernel, image, or its a hardware issue?

Thanks in advance.

James



--
View this message in context: http://gumstix.8.n6.nabble.com/SET-failed-on-device-wlan0-No-such-device-Error-tp657513p4965513.html
Sent from the Gumstix mailing list archive at Nabble.com.

------------------------------------------------------------------------------
How fast is your code?
3 out of 4 devs don\\\'t know how their code performs in production.
Find out how slow your code is with AppDynamics Lite.
http://ad.doubleclick.net/clk;262219672;13503038;z?
http://info.appdynamics.com/FreeJavaPerformanceDownload.html
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users


------------------------------------------------------------------------------
How fast is your code?
3 out of 4 devs don\\\'t know how their code performs in production.
Find out how slow your code is with AppDynamics Lite.
http://ad.doubleclick.net/clk;262219672;13503038;z?
http://info.appdynamics.com/FreeJavaPerformanceDownload.html
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SET failed on device wlan0 ; No such device. Error

kfcandroid
It's really sad that seems like I don't have any wlan device available...
The result of 'iwconfig' is as following:

root@overo:~# iwconfig
lo        no wireless extensions.

eth1      no wireless extensions.

Any idea or suggestion?
Maybe I really should change to different build of kernel and/or image?

James
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: SET failed on device wlan0 ; No such device. Error

kfcandroid
Special thanks to David M. for the great advise

After I replaced the original Gumstix pre-built stable image by Developer's image, the Wi-Fi device wlan0 finally is on the list! No I am going to configure it, hopefully there's not too many trouble ahead.
Thanks for helping me out, guys :D
Loading...