Problem in Buildroot JamVM 1.5 with Classpath 0.96/.1

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Problem in Buildroot JamVM 1.5 with Classpath 0.96/.1

Safdar
Dear all,
Did anybody ever tried to build a new Buildroot with the latest JamVM 1.5 and
the latest Classpath 0.96/.1?
I have been trying to compile it but always get errors :-(

Should I go back to JamVM 1.4?
Please share your experiences ...

Kind regards.
Safdar.


-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem in Buildroot JamVM 1.5 with Classpath 0.96/.1

Robert Dodier
Administrator
Safdar wrote
Did anybody ever tried to build a new Buildroot with the latest JamVM 1.5 and
the latest Classpath 0.96/.1?
I have been trying to compile it but always get errors :-(

Should I go back to JamVM 1.4?
Please share your experiences ...
I have successfully built & run JamVM 1.5.0 + Classpath 0.96.1 + buildroot r1545.
I tried many combinations of previous JamVM & Classpath versions,
and in most cases, maybe all, there was some kind of strangeness.
E.g. segfault, boot classpath strangeness, other runtime strangeness,
or some combinations failed to build. My advice is to keep trying the
most recent JamVM + most recent Classpath. Maybe you can tell us
what are the specific errors you are getting.

JamVM + Classpath problems have been discussed on the Gumstix mailing
list from time to time. Take a look at the archive (e.g. at Nabble.com).

HTH

Robert Dodier
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem in Buildroot JamVM 1.5 with Classpath 0.96/.1

Safdar
Dear Robert,
Thanks for your reply ... I tried to buildroot with the most recent revision
(1578) and getting errors ....
Do you recommend that I try again by downloading the revision 1545???

Secondly, the errors what I was getting related to Java compilation .. e.g.
class cast exception etc.. I installed Java 1.5 on my host Linux computer
and tried to buildroot .. but always failed .. then I switched back to JamVM
1.4 and Classpath 0.95 and it was compiled successfully ...

Rgrds.
Safdar.


-------------------------------------------------------------------------
Check out the new SourceForge.net Marketplace.
It's the best place to buy or sell services for
just about anything Open Source.
http://ad.doubleclick.net/clk;164216239;13503038;w?http://sf.net/marketplace
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem in Buildroot JamVM 1.5 with Classpath 0.96/.1

Robert Dodier
Administrator
Safdar wrote
Thanks for your reply ... I tried to buildroot with the most recent revision
(1578) and getting errors ....
Do you recommend that I try again by downloading the revision 1545???
I doubt if it is necessary to do that, but I guess it is possible that
something has changed in buildroot which makes r1578 fail ...

In general I have found that it works better to compile all of buildroot
without JamVM or Classpath or other add-ons. After you get the
base system compiled, then use make menuconfig to enable JamVM
and Classpath and build just those things. Dunno if that is applicable
to your case.

Safdar wrote
Secondly, the errors what I was getting related to Java compilation .. e.g.
class cast exception etc.. I installed Java 1.5 on my host Linux computer
and tried to buildroot .. but always failed .. then I switched back to JamVM
1.4 and Classpath 0.95 and it was compiled successfully ...
Try compiling with jikes instead of javac. I think you need to change
the classpath.mk file to specify the --with-jikes option.

I also successfully compiled JamVM 1.4.something + Classpath 0.95,
but I encountered various runtime errors. I don't recommend that.

HTH

Robert Dodier
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem in Buildroot JamVM 1.5 with Classpath 0.96/.1

RobbyD
In reply to this post by Robert Dodier
>I have successfully built & run JamVM 1.5.0 + Classpath 0.96.1 + buildroot r1545.

How to you update/configure the buildroot to install the updated versions of JamVM and Classpath?

Rob


Robert Dodier wrote
Safdar wrote
Did anybody ever tried to build a new Buildroot with the latest JamVM 1.5 and
the latest Classpath 0.96/.1?
I have been trying to compile it but always get errors :-(

Should I go back to JamVM 1.4?
Please share your experiences ...
I have successfully built & run JamVM 1.5.0 + Classpath 0.96.1 + buildroot r1545.
I tried many combinations of previous JamVM & Classpath versions,
and in most cases, maybe all, there was some kind of strangeness.
E.g. segfault, boot classpath strangeness, other runtime strangeness,
or some combinations failed to build. My advice is to keep trying the
most recent JamVM + most recent Classpath. Maybe you can tell us
what are the specific errors you are getting.

JamVM + Classpath problems have been discussed on the Gumstix mailing
list from time to time. Take a look at the archive (e.g. at Nabble.com).

HTH

Robert Dodier
Loading...