Quantcast

Overo earth hang on booting the kernel - pls help

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Overo earth hang on booting the kernel - pls help

mdersch
Hi @ all,

10 Month ago, i bought a overo earth and summit-Board. It runs pretty good. Since a few days the kernel don't boot. After the message "Uncompressing Linux... done, booting the kernel.", the board begins at the start again.

Putty-log:------------------------------------------------
Texas Instruments X-Loader 1.5.1 (Jan 22 2012 - 11:08:14)
OMAP3503-GP ES3.1
Board revision: 1
Reading boot sector
Loading u-boot.bin from mmc


U-Boot 2011.09 (Jan 06 2012 - 13:51:09)

OMAP3503-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 600 mHz
Gumstix Overo board + LPDDR/NAND
I2C:   ready
DRAM:  512 MiB
NAND:  512 MiB
MMC:   OMAP SD/MMC: 0
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Board revision: 1
Direct connection on mmc2
No EEPROM on expansion board
Die ID #5cbc0024000000000403a6c40a007010
Net:   No ethernet found.
Hit any key to stop autoboot:  0
reading boot.scr

** Unable to read "boot.scr" from mmc 0:1 **
reading uImage

3091316 bytes read
Booting from mmc ...
## Booting kernel from Legacy Image at 82000000 ...
   Image Name:   Angstrom/3.0/overo
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    3091252 Bytes = 2.9 MiB
   Load Address: 80008000
   Entry Point:  80008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK
OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
£tصb$U
 @¨H¨HU¯¬.HR·.]®][Y·ºs X-Loader 1.5.1 (Jan 22 2012 - 11:08:14)
OMAP3503-GP ES3.1
Board revision: 1
Reading boot sector
Loading u-boot.bin from mmc


U-Boot 2011.09 (Jan 06 2012 - 13:51:09)

OMAP3503-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 600 mHz
Gumstix Overo board + LPDDR/NAND
I2C:   ready
DRAM:  512 MiB
NAND:  512 MiB
MMC:   OMAP SD/MMC: 0
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Board revision: 1
Direct connection on mmc2
No EEPROM on expansion board
Die ID #5cbc0024000000000403a6c40a007010
Net:   No ethernet found.
Hit any key to stop autoboot:  0
reading boot.scr

** Unable to read "boot.scr" from mmc 0:1 **
reading uImage

3091316 bytes read
Booting from mmc ...
## Booting kernel from Legacy Image at 82000000 ...
   Image Name:   Angstrom/3.0/overo
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    3091252 Bytes = 2.9 MiB
   Load Address: 80008000
   Entry Point:  80008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK
OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
£tصb$U
 ×H¨HU¯¬.HR·.]®][Y·ºs X-Loader 1.5.1 (Jan 22 2012 - 11:08:14)
OMAP3503-GP ES3.1
Board revision: 1
Reading boot sector
-------------------------------------------------------------------------------------
I have a micro sd card, as described in the link created
http://gumstix.org/create-a-bootable-microsd-card.html

I have used an gumstix rootfs (omap3-console-image-overo.tar.bz2) from this link

As well, the MLO, u-boot.bin, uImage

For more than three days, I'm sitting on this problem and just google has not helped me.

I hope someone can help me.
Thank you in advance.
Manfred

P.S.: Please excuse my bad english.



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Overo earth hang on booting the kernel - pls help

Neil MacMunn
Hi Manfred,

How are you powering your Summit?

-
Neil

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Overo earth hang on booting the kernel - pls help

mdersch
Hi Neil,

thank you for reply. I powered my Summit with a professional power supply with 5V and 2A.
If i turn on power the blue and green LED on Overo-Earth board turn on.

After "Uncompressing Linux... done, booting the kernel." the blue LED on overo-board turns off and the red LED on summit-Board turn on. On Putty, the Board start again and the red LED on summit turn off and the blue LED on Overo-Board turn on. The green LED on overo-board lights always.

I suspect your suspicion, that probably the power supply does not provide the necessary performance, but i have tried a few other power supplies. i have measured a voltage on the summit-board of 4.94V and the power-supply show a current of 200mA. At the "restart" the voltage fall down to 4.88V.

Manfred
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Overo earth hang on booting the kernel - pls help

mdersch
Hi @ all,

it is unbelievable!

I have few professionals Powersupplies. And the overo+summit isn't booting with them. I'm desperate at this problem.

A big thank you to Neil. He brought me to thinking about the power supply. Just, I bought in a supermarket a cheap universal power supply for 15 euro. And i see! the overo+summit boots perfect. I can not believe it still.

it is to fight hair. I spent days with this problem now and a little cheap power solves it.

I am writing this response may help others to be able to.

Manfred
Loading...