Quantcast

No configuration fragments found

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

No configuration fragments found

felix
Hey,

Recently I was building a 3.0 kernel by using Yocto poky.
1) I created my own linux-overo-3.0.bb file under the directory of '/meta-gumstix/recipes-kernel/linux/'. It is quite simple and straightforward.  
 linux-overo-3.bb
2) I copied a defconfig file to the directory of '/meta-gumstix/recipes-kernel/linux/linux-overo-3.0'.
3) I revised the overo.conf under the directory of 'meta-gumstix/conf/machine/' with PREFERRED_PROVIDER_virtual/kernel ?= "linux-overo" and PREFERRED_VERSION_linux-overo = "3.0%"

But when i use bitbake virtual/kernel, I got a error like

Log data follows:
| DEBUG: Executing shell function do_kernel_configme
| NOTE: kernel configme
| [INFO] Configuring target/machine combo: "standard/overo"
| [INFO] collecting configs in .meta/meta-series
| [ERROR] No configuration fragments found, this typically is a misconfigured BSP.
|         Check that fragments (or defconfigs) are referenced by the board description.
| config of "standard/overo" failed
| WARNING: exit code 1 from a shell command.
| ERROR: Function failed: do_kernel_configme

I have tried the default linux-gumstix-3.2.bb and it works well. Is there any more variables I need to revise? I also have another question, where can I find necessary patches for linux 3.0 on Gumstix overo?

thanks for your help,
Felix
Loading...