Quantcast

IronSTORM COM not fully booting

classic Classic list List threaded Threaded
4 messages Options
pg
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

IronSTORM COM not fully booting

pg
Hello,

I have a Gumstix IronSTORM COM and A Pinto-TH board.

When I hook up 5v+GND to the Pinto without the gumstix attached, the red and blue LEDs sometimes illuminate. I have to fiddle with the connections. They seem very loose. When I plug the gumstix in, the green light on the gumstix turns on and the blue and red LEDs on the Pinto turn off. The green light on the gumstix itself seems more stable then the Pinto LEDs .

The issue is I have a bootable Micro-SD card in my gumstix and the red or blue LEDs on the gumstix itself never turn on. If I am correct when the blue LED on the IronSTORM itself illuminates it means that it is reading from the SD card, while the red light means something to do with the kernel. Why is it not booting properly (not reading from my SD card)?
pg
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: IronSTORM COM not fully booting

pg
Bump.

I think I need to clarify,

I connect power to my Gumstix with a bootable micro SD card plugged in. Except only the green light turns on, meaning it is not reading the SD card because the blue light is not illuminating, thus, not fully booting.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: IronSTORM COM not fully booting

Greg Kogut
The blue light (on my Overos) turns on when the mmc transceiver is detected by u-boot.  It turns regardless of whether a uSD card is actually inserted.

I would connect via the serial console, and inspect the u-boot console output.   This will let you know if u-boot is not loading at all,  if u-boot is working, but the mmc transceiver is not being detected, or if the transceiver is detected, but the LED isn't lighting for some other reason.

Greg





From: pg <[hidden email]>
To: [hidden email]
Sent: Friday, April 27, 2012 6:06 AM
Subject: Re: [Gumstix-users] IronSTORM COM not fully booting

Bump.

I think I need to clarify,

I connect power to my Gumstix with a bootable micro SD card plugged in.
Except only the green light turns on, meaning it is not reading the SD card
because the blue light is not illuminating, thus, not fully booting.

--
View this message in context: http://gumstix.8.n6.nabble.com/IronSTORM-COM-not-fully-booting-tp4931917p4933863.html
Sent from the Gumstix mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users



------------------------------------------------------------------------------
Live Security Virtual Conference
Exclusive live event will cover all the ways today's security and
threat landscape has changed and how IT managers can respond. Discussions
will include endpoint security, mobile security and the latest in malware
threats. http://www.accelacomm.com/jaw/sfrnl04242012/114/50122263/
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
pg
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: IronSTORM COM not fully booting

pg
That sounds like a great idea. The only problem is that the gumstix isn't even getting to the point where it comes up as a device on my computer.
Loading...