Quantcast

Gumstix Robovero wifi not getting connected

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Gumstix Robovero wifi not getting connected

zafrullahsyed
I am using Gumstix Robovero with Yocto Project. My linux kernel is Linux overo 3.5.7.

I followed instructions from http://wiki.gumstix.org/index.php?title=Overo_Wifi and found out that it is nearly similiar to what you have set.

my wifi is wpa-psk.

iwconfig output:

root@overo:~# iwconfig
lo        no wireless extensions.

wlan0      IEEE 802.11bg  ESSID:off/any  
              Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:on

iwlist scan:

root@overo:~# iwlist scan
lo        Interface doesn't support scanning.

wlan0     Scan completed :
                    Cell 01 - Address: 10:FE:ED:7F:48:66
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=52/70  Signal level=-58 dBm  
                    Encryption key:on
                    ESSID:"gumstixnet"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=00000000070118fa
                    Extra: Last beacon: 609ms ago
                    IE: Unknown: 000A67756D737469786E6574
                    IE: Unknown: 010882848B968C129824
                    IE: Unknown: <a href="tel:030101" value="+4930101" target="_blank">030101
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: 2A0100
                    IE: Unknown: 3204B048606C
                    IE: Unknown: DD180050F2020101860003A4000027A4000042435E0062322F00
                    IE: Unknown: DD0900037F01010000FF7F
                    IE: Unknown: DD0A00037F04010006004000
                    IE: Unknown: DD850050F204104A0001101044000102103B000103104700100000000000001000000010FEED7F48661021000754502D4C494E4B1023000B544C2D5752313034334E4410240003312E3010420003312E301054000800060050F20400011011001B576972656C65737320526F7574657220544C2D5752313034334E44100800020086103C000101

ifconfig output:

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:<a href="tel:16436" value="+4916436" target="_blank">16436  Metric:1
          RX packets:32 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:2656 (2.5 KiB)  TX bytes:2656 (2.5 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:19:88:45:22:14  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


By default my /etc/network/interfaces is:

# Wireless interfaces
iface wlan0 inet dhcp
        wireless_mode managed
        wireless_essid any
        wpa-driver wext
        wpa-conf /etc/wpa_supplicant.conf

By default /etc/wpa_supplicant.conf:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
update_config=1

network={
        key_mgmt=NONE
}

############### Modification 1 #########################

1) /etc/network/interfaces not changed.

2) Modified /etc/wpa_supplicant.conf:
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=0
    update_config=1
    eapol_version=1
    ap_scan=1
    fast_reauth=1

    network={
            ssid="gumstixnet"
            proto=WPA
            key_mgmt=WPA-PSK
            pairwise=CCMP TKIP
            group=CCMP TKIP
            scan_ssid=1
            psk="xxxx"
            priority=10
    }

3) ifdown wlan0 && ifup wlan0

root@overo:~# ifdown wlan0 && ifup wlan0
ifdown: interface wlan0 not configured
Successfully initialized wpa_supplicant
ctrl_iface exists and seems to be in use - cannot override it
Delete '/var/run/wpa_supplicant/wlan0' manually if it is not used anymore
Failed to initialize control interface '/var/run/wpa_supplicant'.
You may have another wpa_supplicant process already running or the file was
left by an unclean termination of wpa_supplicant in which case you will need
to manually remove this file before starting wpa_supplicant again.

[ 1041.419006] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
udhcpc (v1.21.1) started
Sending discover...
Sending discover...
Sending discover...
No lease, failing

root@overo:~# [ 1073.778747] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 1073.803100] cfg80211: Calling CRDA to update world regulatory domain
[ 1073.865600] cfg80211: World regulatory domain updated:
[ 1073.874420] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 1073.892822] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1073.910888] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 1073.929077] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 1073.943969] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1073.961791] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)


No success for this.

############### Modification 2 #########################

1) /etc/network/interfaces:

auto wlan0
iface wlan0 inet dhcp
     pre-up wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf -B
      down killall -q wpa_supplicant
 Wireless interfaces

2) /etc/wpa_supplicant.conf:

Not changed, same as in Modification 1.

3) Output of ifdown wlan0 && ifup wlan0:

root@overo:~# ifdown wlan0 && ifup wlan0
ifdown: interface wlan0 not configured
Successfully initialized wpa_supplicant
udhcpc (v1.21.1) started
Sending discover...
[  160.578735] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  160.596984] cfg80211: Calling CRDA to update world regulatory domain
[  160.662719] cfg80211: World regulatory domain updated:
[  160.672424] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  160.685119] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  160.697265] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  160.710510] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  160.722656] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  160.735260] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Sending discover...
Sending discover...
No lease, failing
root@overo:~# [  173.392120] cfg80211: Calling CRDA to update world regulatory domain
[  173.453735] cfg80211: World regulatory domain updated:
[  173.463256] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  173.476135] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  173.489562] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  173.503021] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  173.515380] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  173.527282] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  174.473266] cfg80211: Calling CRDA to update world regulatory domain
[  174.528381] cfg80211: World regulatory domain updated:
[  174.533813] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  174.550109] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  174.562164] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  174.574188] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  174.586029] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  174.598602] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

############### Modification 3 #########################

1) /etc/network/interfaces:

# Wireless interfaces
auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-ssid "gumstixnet"
wpa-psk "gumstix2013"

2) /etc/wpa_supplicant.conf:

Not changed, same as Modification 1.

 from console:
root@overo:~# ifconfig wlan0 down
root@overo:~# ifconfig wlan0 up 
root@overo:~# [  616.044311] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
root@overo:~# [  697.005462] cfg80211: World regulatory domain updated:
[  697.010894] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  697.027343] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  697.039367] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  697.051483] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  697.063385] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  697.075836] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)

############### No wifi after trying all these methods  ##############

Now after Modification 1,2,3 my ifconfig output is as follows:

root@overo:~# ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:<a href="tel:16436" value="+4916436" target="_blank">16436  Metric:1
          RX packets:96 errors:0 dropped:0 overruns:0 frame:0
          TX packets:96 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:7968 (7.7 KiB)  TX bytes:7968 (7.7 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:19:88:45:22:14  
          inet6 addr: fe80::219:88ff:fe45:2214/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:19 errors:0 dropped:0 overruns:0 frame:0
          TX packets:19 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2147 (2.0 KiB)  TX bytes:2403 (2.3 KiB)

After few seconds I am getting these messages on my screen:

root@overo:~# [  800.898315] cfg80211: Calling CRDA to update world regulatory domain
[  800.956512] cfg80211: World regulatory domain updated:
[  800.966217] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  800.978607] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  800.990936] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  801.002960] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  801.014892] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  801.027191] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  861.656097] cfg80211: Calling CRDA to update world regulatory domain
[  861.713439] cfg80211: World regulatory domain updated:
[  861.722625] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[  861.735748] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  861.747802] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  861.759735] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[  861.771728] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[  861.783935] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)


I followed the instructions here and I have crda recipe in my Image.

1) Edited the file:
# Example file, should be put in /etc/udev/rules.d/regulatory.rules

KERNEL=="regulatory*", ACTION=="change", SUBSYSTEM=="platform", RUN+="/sbin/crda"

2) Using iw to change regulatory domains
     iw reg set US
3) I did not understand after that point?

These methods I have tried but all were unsuccessful.

If Any one can give me any inputs that would be great.

Many Thanks and Regards,
Zafrullah

------------------------------------------------------------------------------
Sponsored by Intel(R) XDK
Develop, test and display web and hybrid apps with a single code base.
Download it for free now!
http://pubads.g.doubleclick.net/gampad/clk?id=111408631&iu=/4140/ostg.clktrk
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Loading...