Quantcast

Fwd: Enable Spidev on Gumtix with Linaro onboard

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Fwd: Enable Spidev on Gumtix with Linaro onboard

DreamDay
Hello!

How I can enable SPIDEV interface in Linaro OS?

I can't find instructions...

Best regards, Eugene.

Sorry for my English.

------------------------------------------------------------------------------
Precog is a next-generation analytics platform capable of advanced
analytics on semi-structured data. The platform includes APIs for building
apps and a phenomenal toolset for data science. Developers can use
our toolset for easy data analysis & visualization. Get a free account!
http://www2.precog.com/precogplatform/slashdotnewsletter
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Fwd: Enable Spidev on Gumtix with Linaro onboard

torenorh
I'm having the same problem and could really use some help.

I get spi1.0 and spi1.1 in /sys/bus/spi/devices, but nothing in /dev.
Have tried make menuconfig and enabling "Altera spi controller" and "user mode SPI device driver support", but when I try to make I get the error "No rule to make target `arch/arm/tools/gen-mach-types` ..  
Tried following the guidelines at http://www.jumpnowtek.com/index.php?option=com_content&view=article&id=57&Itemid=62 under notes pt.2, but no success.

Using 3.2.1-linaro-omap. Any help would be greatly appreciated, thanks!  :)

All the best,
Tore
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Fwd: Enable Spidev on Gumtix with Linaro onboard

xcancerberox
Hi,

On Tue, Jun 25, 2013 at 7:45 AM, torenorh <[hidden email]> wrote:
> I'm having the same problem and could really use some help.
>
> I get spi1.0 and spi1.1 in /sys/bus/spi/devices, but nothing in /dev.
> Have tried make menuconfig and enabling "Altera spi controller" and "user
> mode SPI device driver support", but when I try to make I get the error "No
> rule to make target `arch/arm/tools/gen-mach-types` ..
> Tried following the guidelines at
> http://www.jumpnowtek.com/index.php?option=com_content&view=article&id=57&Itemid=62
> under notes pt.2, but no success.


may be your problem is that you have other modules running that
conflicts with spidev.
For example the modules for "ADS7846" (touchscreen) and "LGPHILIPS
LB035Q02" (screen LCD) use the spi device and they overrun the module
spidev.

>
> Using 3.2.1-linaro-omap. Any help would be greatly appreciated, thanks!  :)

My definitive solution was recompile the kernel without these options:
Device Drivers  --->
   Input device support  --->
     [ ]   Touchscreens  --->
       < >   ADS7846/TSC2046/AD7873 and AD(S)7843 based touchscreens (NEW)
   Graphics support  --->
     {*} OMAP2+ Display Subsystem support (EXPERIMENTAL)  --->
       OMAP2/3 Display Device Drivers  --->
         < > LG.Philips LB035Q02 LCD Panel

Regards,
Joaquin de Andres

------------------------------------------------------------------------------
This SF.net email is sponsored by Windows:

Build for Windows Store.

http://p.sf.net/sfu/windows-dev2dev
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Loading...