Quantcast

Caspa VL on AirSTORM, not video capture device

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Caspa VL on AirSTORM, not video capture device

smarsh
I'm struggling with capturing images from the Caspa VL. Here's where I run into trouble:

# mplayer tv:// -tv driver=v4l2:device=/dev/video0 -vo png -frames 1

This gives a message "Device /dev/video0 is not a video capture device." and does not capture the frame.

I'm running the current (22 Jan 2012) omap3-console-image-overo pre-built developer image from cumulus, running atop a 3.0.0 kernel and haven't had any other issues thus far. I've also connected the Caspa to the Overo as instructed in the Caspa Camera Board how-to over at gumstix.org (http://wiki.gumstix.org/index.php?title=Caspa_camera_boards).

During the boot sequence it seems to detect the camera and load the mt9v032 drivers:

mt9v032 3-005c: Probing MT9V032 at address 0x5c
overo: setting xclk to 25000000 hz
overo: setting xclk to 0 hz
mt9v032 3-005c: MT9V032 detected at address 0x5c
overo: setting xclk to 25000000 hz
overo: setting xclk to 0 hz

Also checking with modprobe reveals:
# modprobe -r mt9v032
FATAL: Module mt9v032 is in use.

I've also seen some other unusual behavior. When I initially powered down the board and connected the camera (contact up on the camera board, contact down on the Overo) the Overo did not power back on after reconnecting the power. Thinking perhaps the how-to on the wiki was outdated I tried again with the camera board connection reversed (contact side down). It booted, but it became clear the wiki wasn't wrong so I connected it properly and since then the board will power on with it connected.

Also, if I restart via shutdown -r now, it won't detect and load mt9v032 during the boot process. It does however do it after a halt.

Finally, regardless of whether the camera is connected I always see /dev/video0 through /dev/video5. It's my understanding that /dev/video0 should be the camera but don't understand what these devices are and why they are all present independent of a connected camera.

I'm still somewhat new to Linux and have scoured the web for resources and others experiencing similar problems but have not had much luck as far as a solution. Any help would be greatly appreciated.
Loading...