Quantcast

Bluetooth on 2.6.39-pm kernel?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Bluetooth on 2.6.39-pm kernel?

MarcusJ
Hi!
I have trouble getting the bluetooth up and working on my build. I'm using the 2.6.39 pm branch.
For some reason the bluetooth doesn't seem to be detected by the system.
If I run hciconfig it doesn't show anything. No bluetooth device seems to be present.
All other builds I've tried have bluetooth up and working.

Have someone had similar problems?

Thanks
Marcus
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Bluetooth on 2.6.39-pm kernel?

Rich Malavon
Did you try to hci attach ttyO1 as csr noflow

--
Rich

On Mar 21, 2012, at 3:17 PM, MarcusJ <[hidden email]> wrote:

> Hi!
> I have trouble getting the bluetooth up and working on my build. I'm using
> the 2.6.39 pm branch.
> For some reason the bluetooth doesn't seem to be detected by the system.
> If I run hciconfig it doesn't show anything. No bluetooth device seems to be
> present.
> All other builds I've tried have bluetooth up and working.
>
> Have someone had similar problems?
>
> Thanks
> Marcus
>
> --
> View this message in context: http://gumstix.8.n6.nabble.com/Bluetooth-on-2-6-39-pm-kernel-tp4641950p4641950.html
> Sent from the Gumstix mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> This SF email is sponsosred by:
> Try Windows Azure free for 90 days Click Here
> http://p.sf.net/sfu/sfd2d-msazure
> _______________________________________________
> gumstix-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gumstix-users

------------------------------------------------------------------------------
This SF email is sponsosred by:
Try Windows Azure free for 90 days Click Here
http://p.sf.net/sfu/sfd2d-msazure
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Bluetooth on 2.6.39-pm kernel?

MarcusJ
Thanks for the reply.
Yes, I tried hciattach. The output i got was this:
CSR build ID <some_hexnumbers>
Can't set line discipline: Invalid argument
Can't initialize device: Invalid argument


I guess the problem lies with the driver not finding the device. But I have no idea how to confirm this or how to fix it.

/ Marcus

Rich Malavon wrote
Did you try to hci attach ttyO1 as csr noflow

--
Rich

On Mar 21, 2012, at 3:17 PM, MarcusJ <[hidden email]> wrote:

> Hi!
> I have trouble getting the bluetooth up and working on my build. I'm using
> the 2.6.39 pm branch.
> For some reason the bluetooth doesn't seem to be detected by the system.
> If I run hciconfig it doesn't show anything. No bluetooth device seems to be
> present.
> All other builds I've tried have bluetooth up and working.
>
> Have someone had similar problems?
>
> Thanks
> Marcus
>
> --
> View this message in context: http://gumstix.8.n6.nabble.com/Bluetooth-on-2-6-39-pm-kernel-tp4641950p4641950.html
> Sent from the Gumstix mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> This SF email is sponsosred by:
> Try Windows Azure free for 90 days Click Here
> http://p.sf.net/sfu/sfd2d-msazure
> _______________________________________________
> gumstix-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gumstix-users

------------------------------------------------------------------------------
This SF email is sponsosred by:
Try Windows Azure free for 90 days Click Here
http://p.sf.net/sfu/sfd2d-msazure
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Bluetooth on 2.6.39-pm kernel?

MarcusJ
In reply to this post by MarcusJ
After messing around a bit with the kernel configuration in the build process it seems like i've got it up and working. However the blue bluetooth led is constantly alight.
It doesn't do this in the other builds i've tried. Usually it seems to indicate when the bluetooth is transmitting.
Do someone know why it is always alight?

/Marcus
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Bluetooth on 2.6.39-pm kernel?

Ash Charles
Hi,

The blue led is turned on to signal that the wifi is active.  There
may be some controls within the libertas driver to control this but I
actually haven't dug into this code.

-Ash

On Thu, Mar 29, 2012 at 11:42 PM, MarcusJ <[hidden email]> wrote:

> After messing around a bit with the kernel configuration in the build process
> it seems like i've got it up and working. However the blue bluetooth led is
> constantly alight.
> It doesn't do this in the other builds i've tried. Usually it seems to
> indicate when the bluetooth is transmitting.
> Do someone know why it is always alight?
>
> /Marcus
>
> --
> View this message in context: http://gumstix.8.n6.nabble.com/Bluetooth-on-2-6-39-pm-kernel-tp4641950p4670211.html
> Sent from the Gumstix mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> This SF email is sponsosred by:
> Try Windows Azure free for 90 days Click Here
> http://p.sf.net/sfu/sfd2d-msazure
> _______________________________________________
> gumstix-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gumstix-users

------------------------------------------------------------------------------
This SF email is sponsosred by:
Try Windows Azure free for 90 days Click Here
http://p.sf.net/sfu/sfd2d-msazure
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Bluetooth on 2.6.39-pm kernel?

MarcusJ
This post was updated on .
The wifi led is acting as normal. It was the bluetooth led that was alight all the time.
It is only on the pm kernel that I've had it behave this way so I was simple a bit curious to why it did that.
Bluetooth seems to be functioning as normal and I can disable the led.

/Marcus

Ash Charles wrote
Hi,

The blue led is turned on to signal that the wifi is active.  There
may be some controls within the libertas driver to control this but I
actually haven't dug into this code.

-Ash

On Thu, Mar 29, 2012 at 11:42 PM, MarcusJ <[hidden email]> wrote:
> After messing around a bit with the kernel configuration in the build process
> it seems like i've got it up and working. However the blue bluetooth led is
> constantly alight.
> It doesn't do this in the other builds i've tried. Usually it seems to
> indicate when the bluetooth is transmitting.
> Do someone know why it is always alight?
>
> /Marcus
>
> --
> View this message in context: http://gumstix.8.n6.nabble.com/Bluetooth-on-2-6-39-pm-kernel-tp4641950p4670211.html
> Sent from the Gumstix mailing list archive at Nabble.com.
>
> ------------------------------------------------------------------------------
> This SF email is sponsosred by:
> Try Windows Azure free for 90 days Click Here
> http://p.sf.net/sfu/sfd2d-msazure
> _______________________________________________
> gumstix-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/gumstix-users

------------------------------------------------------------------------------
This SF email is sponsosred by:
Try Windows Azure free for 90 days Click Here
http://p.sf.net/sfu/sfd2d-msazure
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Loading...