Bluetooth Errors on startup?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
22 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Bluetooth Errors on startup?

glen@jetsoftdev.com

Hi All,


I get these errors on startup for Bluetooth for Duovero COM with Aero Core 2. I am not using Bluetooth yet so it is not paired with anything.   Does this mean it is not configured or does it mean my hardware and drivers are not working?




[   10.071655] ---[ end trace f3a6fb073f35be80 ]---

[   10.081329] omap-abe-twl6040 sound: twl6040-legacy <-> 40132000.mcpdm mapping ok

[   10.277069] cfg80211: Calling CRDA to update world regulatory domain

[   10.446746] mwifiex: rx work enabled, cpus 2

[   10.486175] Bluetooth: Core ver 2.19

[   10.490142] NET: Registered protocol family 31

[   10.494842] Bluetooth: HCI device and connection manager initialized

[   10.501831] Bluetooth: HCI socket layer initialized

[   10.501831] Bluetooth: L2CAP socket layer initialized

[   10.512512] Bluetooth: SCO socket layer initialized

[   10.617431] Bluetooth: vendor=0x2df, device=0x911a, class=255, fn=2

[   10.754241] random: nonblocking pool is initialized

[   11.301116] mwifiex_sdio mmc1:0001:1: FW already running! Skip FW dnld

[   11.518768] mwifiex_sdio mmc1:0001:1: WLAN FW is active

[   11.917358] Bluetooth: vendor=0x2df, device=0x911b, class=255, fn=3

[   12.032440] ieee80211 phy0: ignoring F/W country code US

[   12.068939] mwifiex_sdio mmc1:0001:1: driver_version = mwifiex 1.0 (14.66.9.p96) 

[   12.703643] mwifiex_sdio mmc1:0001:1 wlan0: renamed from mlan0

[   16.929016] Bluetooth: module_cfg_cmd(f1) failed


[   21.929016] Bluetooth: PSMODE command failed


[   26.929016] Bluetooth: HSCFG command failed


Thanks in Advance,

Glen

-- 
Glen Wernersbach 
Business, Innovation and Technical Consultant;
Founder and CEO 
ROSettaLABS.io


629 Old St Rt. 74 – Suite 210
Cincinnati, Oh 45244
513-240-9929

------------------------------------------------------------------------------
Find and fix application performance issues faster with Applications Manager
Applications Manager provides deep performance insights into multiple tiers of
your business applications. It resolves application problems quickly and
reduces your MTTR. Get your free trial!
https://ad.doubleclick.net/ddm/clk/302982198;130105516;z
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

Andrew C. Smith
Hi Glen,

What revision of DuoVero are you using?  Can you post the information from the white sticker?  Where are you getting your software from?


Thanks,

Andrew
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

glen@jetsoftdev.com
Andrew, 

The sticker shows:
WO 51385 15-45 BRD900000000178

My build comes from the yocto repository following the directions for latest stable.

Glen


--
Glen Wernersbach View my profile on LinkedInView Profile
Business, Innovation and Technical Consultant;
President and CEO
Jetsoft Development Co.
629 Old St. Rt. 74 - Suite 210
Cincinnati Ohio 45244
513-240-9929
--


On Apr 19, 2016, at 9:35 PM, Andrew C. Smith <[hidden email]> wrote:

Hi Glen,

What revision of DuoVero are you using?  Can you post the information from
the white sticker?  Where are you getting your software from?


Thanks,

Andrew




--
View this message in context: http://gumstix.8.x6.nabble.com/Bluetooth-Errors-on-startup-tp4970768p4970771.html
Sent from the Gumstix mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Find and fix application performance issues faster with Applications Manager
Applications Manager provides deep performance insights into multiple tiers of
your business applications. It resolves application problems quickly and
reduces your MTTR. Get your free trial!
https://ad.doubleclick.net/ddm/clk/302982198;130105516;z
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users

------------------------------------------------------------------------------
Find and fix application performance issues faster with Applications Manager
Applications Manager provides deep performance insights into multiple tiers of
your business applications. It resolves application problems quickly and
reduces your MTTR. Get your free trial!
https://ad.doubleclick.net/ddm/clk/302982198;130105516;z
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

Andrew C. Smith
Hi Glen,

That's the sticker on your AeroCore.  I need the sticker on the DuoVero.


Thanks,

Andrew
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

glen@jetsoftdev.com
Andrew,

The white sticker on the Duvero says
W/O 51040 15-35
Gs44302-R3022
INN W/O# 76296

Is that stick you need?

I am also getting this message:
mwifiex_sdio mmc1:0001:1: PREP_CMD: FW is in bad state






I am using the stable(?) version of the firmware which I think was last
updated in december. I open getting more updated software if I get the
repo command but don¹t want bleeding edge.

I have read on the forum that the wifi driver that is included may be sub
standard. A newer is available from the MFG.



Glen



--
Glen Wernersbach View Profile <http://www.linkedin.com/in/GlenWernersbach>
Business, Innovation and Technical Consultant;
Founder and CEO
ROSettaLABS.io


629 Old St Rt. 74 ­ Suite 210
Cincinnati, Oh 45244

513-240-9929
[hidden email]




On 4/27/16, 8:40 AM, "Andrew C. Smith" <[hidden email]> wrote:

>Hi Glen,
>
>That's the sticker on your AeroCore.  I need the sticker on the DuoVero.
>
>
>Thanks,
>
>Andrew
>
>
>
>--
>View this message in context:
>http://gumstix.8.x6.nabble.com/Bluetooth-Errors-on-startup-tp4970768p49707
>84.html
>Sent from the Gumstix mailing list archive at Nabble.com.
>
>--------------------------------------------------------------------------
>----
>Find and fix application performance issues faster with Applications
>Manager
>Applications Manager provides deep performance insights into multiple
>tiers of
>your business applications. It resolves application problems quickly and
>reduces your MTTR. Get your free trial!
>https://ad.doubleclick.net/ddm/clk/302982198;130105516;z
>_______________________________________________
>gumstix-users mailing list
>[hidden email]
>https://lists.sourceforge.net/lists/listinfo/gumstix-users



------------------------------------------------------------------------------
Find and fix application performance issues faster with Applications Manager
Applications Manager provides deep performance insights into multiple tiers of
your business applications. It resolves application problems quickly and
reduces your MTTR. Get your free trial!
https://ad.doubleclick.net/ddm/clk/302982198;130105516;z
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

Andrew C. Smith
Thanks Glen, I just wanted to confirm what version of the DuoVero you're using.  You're using an older version of the DuoVero Zephyr that uses a different wireless and bluetooth chip than our current DuoVero Zephyr-Y version (uses TI WiLink8).

Could your try running the command

"hcitool scan"

and if doesn't give an error, try it with some bluetooth device in pairing mode (so that it will show up when a device searches for it).

Thanks,

Andrew
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

glen@jetsoftdev.com
device is not available  but my phone and Mac are nearby

--
Glen Wernersbach View my profile on LinkedInView Profile
Business, Innovation and Technical Consultant;
President and CEO
Jetsoft Development Co.
629 Old St. Rt. 74 - Suite 210
Cincinnati Ohio 45244
513-240-9929
--


On May 4, 2016, at 6:46 AM, Andrew C. Smith <[hidden email]> wrote:

Thanks Glen, I just wanted to confirm what version of the DuoVero you're
using.  You're using an older version of the DuoVero Zephyr that uses a
different wireless and bluetooth chip than our current DuoVero Zephyr-Y
version (uses TI WiLink8).

Could your try running the command

"hcitool scan"

and if doesn't give an error, try it with some bluetooth device in pairing
mode (so that it will show up when a device searches for it).

Thanks,

Andrew



--
View this message in context: http://gumstix.8.x6.nabble.com/Bluetooth-Errors-on-startup-tp4970768p4970812.html
Sent from the Gumstix mailing list archive at Nabble.com.

------------------------------------------------------------------------------
Find and fix application performance issues faster with Applications Manager
Applications Manager provides deep performance insights into multiple tiers of
your business applications. It resolves application problems quickly and
reduces your MTTR. Get your free trial!
https://ad.doubleclick.net/ddm/clk/302982198;130105516;z
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users

------------------------------------------------------------------------------
Find and fix application performance issues faster with Applications Manager
Applications Manager provides deep performance insights into multiple tiers of
your business applications. It resolves application problems quickly and
reduces your MTTR. Get your free trial!
https://ad.doubleclick.net/ddm/clk/302982198;130105516;z
_______________________________________________
gumstix-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/gumstix-users
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

Andrew C. Smith
Hi Glen,

Ok it sounds like the bluetooth device is not being loaded.  With luck it's a software issue.  What (Yocto?) image are you using?  Where did you get it?


Thanks,

Andrew
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

glen@jetsoftdev.com
Andrew,

From the original message


I am using the stable(?) version of the firmware which I think was last
updated in december. I open getting more updated software if I get the
repo command but don¹t want bleeding edge.
Glen
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

Andrew C. Smith
Hi Glen,

That's not super helpful ... Are you talking about firmware for the AeroCore or the software on the SD card (Yocto)?  I'm interested in where you got the software for the DuoVero that's on the SD card.  Did you download it from a website?  Did you compile it yourself?  Are you using the SD card that came with the DuoVero.  The more information the better so I can see if it's just an old software bug or if it's a hardware issue.

Thanks,

Andrew
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

glen@jetsoftdev.com
Compile it myself from git using the master stable build and yocto. Follow the instructions on line.

Says 1.8 for duovero on boot

--
Glen Wernersbach View my profile on LinkedInView Profile
Business, Innovation and Technical Consultant;
President and CEO
Jetsoft Development Co.
629 Old St. Rt. 74 - Suite 210
Cincinnati Ohio 45244
513-240-9929
--


On May 5, 2016, at 11:09 AM, Andrew C. Smith [via Gumstix] <[hidden email]> wrote:

Hi Glen,

That's not super helpful ... Are you talking about firmware for the AeroCore or the software on the SD card (Yocto)?  I'm interested in where you got the software for the DuoVero that's on the SD card.  Did you download it from a website?  Did you compile it yourself?  Are you using the SD card that came with the DuoVero.  The more information the better so I can see if it's just an old software bug or if it's a hardware issue.

Thanks,

Andrew


If you reply to this email, your message will be added to the discussion below:
http://gumstix.8.x6.nabble.com/Bluetooth-Errors-on-startup-tp4970768p4970834.html
To unsubscribe from Bluetooth Errors on startup?, click here.
NAML
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

Andrew C. Smith
Hi Glen,

Well to debug I'll need to actually try this out and see where the issue is ... my suspicion is software (because your WiFi works right?) ... but I need to verify.  I'll try to find a similar version of DuoVero and test and I'll get back to you.

Thanks,

Andrew
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

glen@jetsoftdev.com
Wifi works for the most part. It is usuable.

 There seems to be some inconsistency on startup and their is a startup message that says no to download firmware because mlan is already up.

This is a message I get sometimes which I think is wifi:

mwifiex_sdio mmc1:0001:1: PREP_CMD: FW is in bad state


--
Glen Wernersbach View my profile on LinkedInView Profile
Business, Innovation and Technical Consultant;
President and CEO
Jetsoft Development Co.
629 Old St. Rt. 74 - Suite 210
Cincinnati Ohio 45244
513-240-9929
--


On May 6, 2016, at 11:31 AM, Andrew C. Smith [via Gumstix] <[hidden email]> wrote:

Hi Glen,

Well to debug I'll need to actually try this out and see where the issue is ... my suspicion is software (because your WiFi works right?) ... but I need to verify.  I'll try to find a similar version of DuoVero and test and I'll get back to you.

Thanks,

Andrew


If you reply to this email, your message will be added to the discussion below:
http://gumstix.8.x6.nabble.com/Bluetooth-Errors-on-startup-tp4970768p4970849.html
To unsubscribe from Bluetooth Errors on startup?, click here.
NAML
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

glen@jetsoftdev.com
In reply to this post by Andrew C. Smith
You asked about wifi. I do get these messages every startup. About skipping FW Dlnd and ignoring country code.

[    9.819824] mwifiex_sdio mmc1:0001:1: FW already running! Skip FW dnld

[    9.930694] mwifiex_sdio mmc1:0001:1: WLAN FW is active

[   10.328979] Bluetooth: vendor=0x2df, device=0x911b, class=255, fn=3

[   10.443054] ieee80211 phy0: ignoring F/W country code US

[   10.503967] mwifiex_sdio mmc1:0001:1: driver_version = mwifiex 1.0 (14.66.9.p96) 

[   10.632293] mwifiex_sdio mmc1:0001:1 wlan0: renamed from mlan0


The I get usually get some message eventually  about calling the CR Registry?

Give me a repo command to try I and will try it.

-- 
Glen Wernersbach 
Business, Innovation and Technical Consultant;
Founder and CEO 
ROSettaLABS.io


629 Old St Rt. 74 – Suite 210
Cincinnati, Oh 45244
513-240-9929

From: Glen Wernersbach <[hidden email]>
Date: Friday, May 6, 2016 at 1:03 PM
To: "Andrew C. Smith [via Gumstix]" <[hidden email]>
Subject: Re: Bluetooth Errors on startup?

Wifi works for the most part. It is usuable.

 There seems to be some inconsistency on startup and their is a startup message that says no to download firmware because mlan is already up.

This is a message I get sometimes which I think is wifi:

mwifiex_sdio mmc1:0001:1: PREP_CMD: FW is in bad state


--
Glen Wernersbach View my profile on LinkedInView Profile
Business, Innovation and Technical Consultant;
President and CEO
Jetsoft Development Co.
629 Old St. Rt. 74 - Suite 210
Cincinnati Ohio 45244
513-240-9929
--


On May 6, 2016, at 11:31 AM, Andrew C. Smith [via Gumstix] <[hidden email]> wrote:

Hi Glen,

Well to debug I'll need to actually try this out and see where the issue is ... my suspicion is software (because your WiFi works right?) ... but I need to verify.  I'll try to find a similar version of DuoVero and test and I'll get back to you.

Thanks,

Andrew


If you reply to this email, your message will be added to the discussion below:
http://gumstix.8.x6.nabble.com/Bluetooth-Errors-on-startup-tp4970768p4970849.html
To unsubscribe from Bluetooth Errors on startup?, click here.
NAML
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

Andrew C. Smith
Hi Glen,

I was finally able to get back to this.  I tried booting up a DuoVero Zephyr with a Wi2Wi chip (like the one you have) and I'm seeing pretty much the same thing as you.  hcitool isn't showing me any devices.  I'm digging deeper into the problem and I'll let you know when I have something.

Thanks,

Andrew
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

glen@jetsoftdev.com
Glad I am not an idiot! 😉

--
Glen Wernersbach View my profile on LinkedInView Profile
Business, Innovation and Technical Consultant;
President and CEO
Jetsoft Development Co.
629 Old St. Rt. 74 - Suite 210
Cincinnati Ohio 45244
513-240-9929
--


On May 16, 2016, at 10:05 AM, Andrew C. Smith [via Gumstix] <[hidden email]> wrote:

Hi Glen,

I was finally able to get back to this.  I tried booting up a DuoVero Zephyr with a Wi2Wi chip (like the one you have) and I'm seeing pretty much the same thing as you.  hcitool isn't showing me any devices.  I'm digging deeper into the problem and I'll let you know when I have something.

Thanks,

Andrew


If you reply to this email, your message will be added to the discussion below:
http://gumstix.8.x6.nabble.com/Bluetooth-Errors-on-startup-tp4970768p4970884.html
To unsubscribe from Bluetooth Errors on startup?, click here.
NAML
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

glen@jetsoftdev.com
In reply to this post by Andrew C. Smith
Andrew,

Any news on this?

Glen
From: "Andrew C. Smith [via Gumstix]" <[hidden email]>
Date: Monday, May 16, 2016 at 10:05 AM
To: Glen Wernersbach <[hidden email]>
Subject: Re: Bluetooth Errors on startup?

Hi Glen,

I was finally able to get back to this.  I tried booting up a DuoVero Zephyr with a Wi2Wi chip (like the one you have) and I'm seeing pretty much the same thing as you.  hcitool isn't showing me any devices.  I'm digging deeper into the problem and I'll let you know when I have something.

Thanks,

Andrew


If you reply to this email, your message will be added to the discussion below:
http://gumstix.8.x6.nabble.com/Bluetooth-Errors-on-startup-tp4970768p4970884.html
To unsubscribe from Bluetooth Errors on startup?, click here.
NAML
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

Andrew C. Smith
I'm able to scan once I issue a couple of commands first.

"hciconfig"

That should list two hci interfaces, note the number of the interface with a valid BD Address.  For me, it was hci0.

"hciconfig hci0 up"

Replace hci0 with whatever you found in the previous step.  Now you should be able to scan.

"hcitool scan"
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

glen@jetsoftdev.com
Andrew, 

I finally got back around to this. It did not configure like I thought it should here is what I got:

[   23.149658] cfg80211: Calling CRDA to update world regulatory domain

[   23.318145] Bluetooth: vendor=0x2df, device=0x911a, class=255, fn=2

[   23.663024] random: nonblocking pool is initialized

[   23.714569] omap-abe-twl6040 sound: twl6040-legacy <-> 40132000.mcpdm mapping ok

[   24.839447] Bluetooth: vendor=0x2df, device=0x911b, class=255, fn=3

[   24.859344] mwifiex: rx work enabled, cpus 2

[   24.871032] mwifiex_sdio mmc1:0001:1: WLAN FW already running! Skip FW dnld

[   24.878387] mwifiex_sdio mmc1:0001:1: WLAN FW is active

[   25.214324] ieee80211 phy0: ignoring F/W country code US

[   25.274017] mwifiex_sdio mmc1:0001:1: driver_version = mwifiex 1.0 (14.66.9.p96) 

[   25.369476] mwifiex_sdio mmc1:0001:1 wlan0: renamed from mlan0

[   29.829437] Bluetooth: module_cfg_cmd(f1) failed


[   34.829315] Bluetooth: PSMODE command failed


[   39.829193] Bluetooth: HSCFG command failed


[ 1046.827850] cfg80211: Calling CRDA to update world regulatory domain

[ 1058.845947] cfg80211: Calling CRDA to update world regulatory domain

root@duovero:~/CarrierCntl# hciconfig

hci1: Type: BR/EDR  Bus: SDIO

BD Address: 00:00:00:00:00:00  ACL MTU: 0:0  SCO MTU: 0:0

DOWN 

RX bytes:113 acl:0 sco:0 events:3 errors:0

TX bytes:39 acl:0 sco:0 commands:2 errors:0


hci0: Type: BR/EDR  Bus: SDIO

BD Address: 00:00:00:00:00:00  ACL MTU: 0:0  SCO MTU: 0:0

DOWN 

RX bytes:0 acl:0 sco:0 events:0 errors:0

TX bytes:32 acl:0 sco:0 commands:1 errors:0


root@duovero:~/CarrierCntl# hciconfig hci0 up


Can't init device hci0: Connection timed out (110)

root@duovero:~/CarrierCntl# 

root@duovero:~/CarrierCntl# hciconfig hci0 up

Can't init device hci0: Connection timed out (110)

root@duovero:~/CarrierCntl# hcitool scan

Device is not available: No such device




Let me know what you see.

Glen
-- 
Glen Wernersbach 
513-240-9929



From: "Andrew C. Smith [via Gumstix]" <[hidden email]>
Date: Wednesday, May 25, 2016 at 8:37 AM
To: Glen Wernersbach <[hidden email]>
Subject: Re: Bluetooth Errors on startup?

I'm able to scan once I issue a couple of commands first.

"hciconfig"

That should list two hci interfaces, note the number of the interface with a valid BD Address.  For me, it was hci0.

"hciconfig hci0 up"

Replace hci0 with whatever you found in the previous step.  Now you should be able to scan.

"hcitool scan"


If you reply to this email, your message will be added to the discussion below:
http://gumstix.8.x6.nabble.com/Bluetooth-Errors-on-startup-tp4970768p4970900.html
To unsubscribe from Bluetooth Errors on startup?, click here.
NAML
Reply | Threaded
Open this post in threaded view
|

Re: Bluetooth Errors on startup?

Andrew C. Smith
Hi Glen,

It's been a while, any movement forward on this?


Thanks,

Andrew
12